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Abstract: In this paper it is given software solution of the problem for robust stability of linear systems with 

time delay via special development program package, which is named "Step method" and by using object 

oriented programming in programming language C
++

. By this it is enabled fast identification of region of 

stability for systems with time delay in parameter plane, when systems are defined by uncertain parameters in 

certain own limits. Via software package it is easy to set parameters of the object,  do the identification of the 

system with time delay, easy enter all important data for the system and present results and graphics of obtaining 

solutions. It is all presented through description of  the program and segments with windows illustrations . The 

crucial value of the development of this programming package is, that the same approach might apply for 

solution of the other variable issues of even more complex systems.  
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I. INTRODUCTION  

The development of the theory and practice of automatic control systems is greatly contributed to the 

high level of modern technology. There is practically no technical discipline in which the automatic control has 

not been applied [1]. Methods of automatic control systems are widely used in choosing the optimal structure 

and determination of parameters of various electronic, telecommunication and computing devices that operate 

on the principle of feedback. 

All events will not take place immediately, from their origin to final implementation still has to pass 

some time [2].  Automatic control systems with delay are incurred as a result of delays at process and /or the 

individual components of the control system. The delay in the system means that the signals information, 

movement, effect through the system are not passed immediately, but with a certain time lag. The existence of 

only one element with the delay in the system can cause a delay in the transmission of signals across the entire 

system. 

In particular, from an engineering standpoint of particular interest is to determine the limits within 

which is subject to change certain of the perturbation (the structural and nonstructural) of the mathematical 

model [3], and in which it is still preserved previously possessed stability properties of the system. In contrast to 

the sensitivity theory, which is considering  only small changes to the relevant parameters of the system, here 

are permitted their large changes and the influence of external factors on the operation of the system  [4].  

A critical part of management problems is the presence of uncertain parameters of the object. It is 

natural that the design parameter managing this uncertainty, is reduced to the corresponding interval limits 

across borders, according to the possibilities that depend on the facilities.  

Object-oriented programming has broad opportunities of application, due to its considerable 

advantages in relation to other programming techniques [5] It can be used for solving simpler tasks, solving 

certain problems in specific scientific fields, setting all expert systems, development of databases and 

information systems, in the context of specific calculations for various modifications and upgrades for its 

compatibility with Windows, and others operating systems [6]. It is sufficient to point out that the well known 

MATLAB software package is developed in object-oriented language C ++, which is presented in this paper 

through a program called "Step method" with respect to the automatic control.  

Instead of data and procedures, object-oriented programming techniques operate with objects and 

messages [7]. Objects are time-varying, and they can be created and deleted. Multiple objects can have some 

common characteristics [8]. Messages are defined by the manipulation of the object execution, or they are 

transferred to other objects to perform [9]. Object oriented programming is a technique that has recently been 

very much used in the development of complex software packages [10-11] . 

In this paper through object-oriented programming it is developed expert program  for "Step method" 

in part of the robustness of linear control systems with delays in the parameter plane. The software is 

characterized by extreme complexity and compactness of the program, which obviously gives a special "force" 

of this kind of programming. 
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II. ROBUST STABILITY OF TIME DELAY SYSTEMS 
When considering any process and its mathematical modeling, delay may be taken into account or not 

[12], otherwise it is to resort to its approximation. It must be immediately noted that in mathematical terms, this 

class of systems are described by differential equations with misplaced argument, which entails great difficulties 

in solving them. On the other hand, as a system of infinite dimensions, their study in the complex domain is 

conditioned by the confrontation with the transcendent transfer functions [13], which require a radical 

reformulation of the existing criteria and methods developed for ordinary linear systems, and often the 

formation of entirely new approaches and methods for solving the tasks for theory of automatic control [14].  

While the parametric methods are exclusively tied to the characteristic equation of the system, it is 

introduced the robustness of the system over the uncertain parameters of the object given in intervals within 

certain limits [15], and this is directly in its coefficients as follows. By using the parameter mappings explicitly 

is contoured region for robust stability of the two adjustable parameters in spite of the presence of any number 

of uncertain parameters of the object, expressed in appropriate intervals [16-17]. 

Application of parametric methods for the synthesis of systems with delay is quite narrow, due to the 

presence of the transcendent member [18]. For this reason, it is observed single-transmission system with a 

delay of a given form as it is presented in the Figure 1. 

 
Figure 1:  Presentation of single transmission system with delays 

 

The transfer function of the open circuit of the Figure 1 is given in the form of: 

where K denotes a gain of the system,  is time delay, and values are determined and always it is K> 0 and > 0. 

The polynomials P (s, p) and Q (s, p) are defined as: 

wherein p represents the parameters of the object, which introduce the robustness of the system through their 

presence in the coefficients of the polynomial P(s,p) and Q (s, p).  

 From the above it can be derived the characteristic equation of the linear systems with delays in the 

following form: 

hRp  represents the vector of the parameters of the object and it is given by p=(p1,p2,…,ph)
T
.  

 Coefficients ak and bk are defined in the following form: 

  

 

 Object parameters are given with intervals of  values contained in the parallelepiped: 
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 Looking at the absolute stability of the system, shown in the complex plane as it is presented in the 

Figure 2, with respect to the location of the roots of the transcendental characteristic equation of the system, it is 

introduced the concept of stability of the transcendental equations. 

 

 
Figure 2:  Presentation of the system of absolute stability in the complex plane 

Family of transcendental equations is C0 stable- if each transcendental equation f(s,p,K,)F has all 

zeroes  skC0, kN.  

According to the foregoing definitions it will be given a theorem that relates to a family of F in relation 

to the absolute stability.  

Family of transcendental equations F is C0 stable if and only if:  

a) for some p
0
, f(s, p

0
, K, ) is C0-stable, 

b)forsC0,, 0 f(s,, K, ). 

 

III. STEP METHOD 

 Step method is used to determine robust stability of linear time delay systems in parameter plane  -K. 

The method is based on the utilization of computer resources in the field of calculating complex mathematical 

operations, sequentially, with the main variable  changing its value from minimum to maximum for . It is 

also carried out parallel calculations for different values of parameters of the object, within the framework 

characteristic of the transcendental equation of the system, which has their own specified threshold, wherein the 

modified parameter values take a pi = (pimax – pimin) / k, where k is 0 , and the values are calculated for  and 

K and are depicted by the corresponding diagram in a parametric plane. On the basis of these displays, it is 

determined the area of stability of the control systems, which is always the left of the curve as seen in the 

direction of the increase in value of . The intersection of all of the obtained regions (nominal six curves in the 

graphs, with the other separated visually) is the desired solution to the area of system stability. 

 All important mathematical interpretation and methods are given on the interface, and basic desktop 

programs, as shown in the Fig. 1. 
 User interface of the program is carried out in the framework of the executable (.exe). The layout and 

presentation of the new document is given by the basic part of the drop-down menus (File, View, Window, and 

Help), in which all items are active (their functions are programmed),  so it is possible to memorize the required 

data (Save or Save as),  when the user enters them and displays the graph, with the extension ".del" and later 

invite them with the function Open.  

 It will be given complete, concise and clear explanation of using the program by items from the menu,  

in the following procedural order: 
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 Data-> Enter values for ‘a’ (Fig 3.) Matrix is dimension of 7 x 6, of the vector a={ao,..,a6}. In the field it is 
entered numbers which might be decimal and integer arguments of the vector p={p1,..,p5}. 

 
Figure 3:  Entering values for ‘a’ 

 

Data-> Enter values for  ‘b’, the same procedure as for  ‘a’. 

 Data-> Enter values for ‘p’ (Fig. 4.). 

 
Figure 4:  Entering values for ‘p’ 

  

Input vector p = {p1, .., p5}, with the exception that the first entries are minimum values of the vector p, and 

then are entered the maximum values, with the value of the subscription step k = {k1, .., k5}, which are included 

in the above form for the conversion . 
 Data-> Enter values for ‘w’, steps and maximums (Fig. 5.).Firstly it is entered a major step for ω, on which base 

is done the loop and then it is calculated the final value. 

 
Figure 5:  Entering values for ‘w’ 
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 Data-> Listing (Fig. 6.). Here it is possible to browse through a number of values of the calculated values of 

τ, K, auxiliary functions RP, RQ, IP, IQ, according to the accepted values for ω and its step Δω. 

 
Figure 6:  Listing of the variables for ‘p’ 

 

 Graph-> Increments of the graph (Fig. 7.). Here the user selects the range of the values that will be displayed 

on the axes representing τ and K with their separation, and the minimum value should not be on the axis 

higher than the maximum value. 

 
Figure 7:  Settings of the graph 
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 Graph-> Setting up the graph. Setting refers to the number of decimal places to be displayed in a number of 

notches on each axes τ and K.. 

 Graph-> Font. As in other windows formatting, here is selected a font through the classic window for this 

purpose. 

 Graph-> The thickness of the line (Fig.8).Here is adjusted nominal thickness of the line curves on the graphs. 

 
Figure 8:  The thickness of the nominal curve 

 

 Graph-> The type of the lines (Fig.9). Line of the curves can be entered in the graph by dots, circles and with 

crosses in places where the calculated value is taken. 

 
Figure 9:  The type of the lines 

 

 Draw-> Graph 1 (an example is shown in Fig. 10). By  changing  from minimum to maximum values, with 

a selected step Δω, it is obtained on the graph, curves of nominal values of decomposition with respect to 

secondary parameters of the object, and for different values of the periodicity factor k (k = 0,1,2,3,4,5). 

 

 
Figure 10:  Presentation of the graph 1 

 

 Draw-> Graph 2 (an example is shown in Fig. 11). It is drawn a nominal decomposition curves and all other 

curves by changing the values of ω and Δω for given parameters of the object p, according to the running 

step of the minimum to maximum values.  Drawing of the Graph 2  is determined by the required stability in 

the area of the parametric plane  - K. 
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Figure 11:  Presentation of the graph 2 

 

 Colors-> Palette 1. Gives the ability to change color plotted graph. 

 Colors-> Palette 2. Gives the ability to change color plotted graph of nominal curves. 

 Stop-> With this function is performed interrupting of program execution, or plotting graphs. 
 File-> New. Opening of new document. 

 File-> Open. Entering into current document. 

 File-> Close. Exit from document. 

 File-> Save, Save As. Storing documents in a specific location. 

 File-> Print. Printing documents. 

 File-> Print Preview. Preview of the document. 

 File-> Print Setup. Adjusting printing features. 

 View-> Toolbar, Status Bar. Activating these elements at desktop. 

 Windows ->New Window, Cascade, Tile, Arrange Icons 

 Help->About Step method. 

 

IV. CONCLUSION  
As in the preceding has presented, this expert program for determining the area of a robust system 

stability with delays in the parameter plane, has achieved a very high quality, viewed as the approach to 

reliability of the realized functions, the ease of operation and design, and it is completely not inferior to the well-

known program MATLAB, and even exceeds it in the field of graphic interpretation of the obtained solutions.  

Object-oriented programming through the C ++ programming language gives excellent possibilities of creation, 

wide range of applications, whose characteristics should be used in an optimal way. Suffice it to point out that 

Windows programs run in that language, as well as the software package MATLAB is also based on it.  

Taking into account that control theory for robust systems with delay is very complex, especially 

because of the transcendental term in the equation, there is necessity to develop efficient software for solving 

stability issues, and presenting graphical solutions. The obtained results are accurate, fast and very well 

presented, so our goal is completely achieved. This software is adaptive and it might be useful for even more 

complex systems such as distributed parameter systems or singular systems. 
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